Forum

Forum

Notifications
Clear all

Loxplán pro připojení meteostanice WarioWeather ME13 (MODBUS TCP)  

Page 5 / 7
  RSS

koldavideo
(@koldavideo)
Noble Member Moderator
Joined: 4 years ago
Posts: 1545
17/12/2018 10:24 am  

No, popravdě já jsem tam kdysi volal a řekli mi, že v některých případech se musí zadávat modbusová adresa - 1. tedy např. místo 1053 je nutné zadat 1052. Moc jsem to nepochopil a ani se mi nad tím nechtělo moc přemýšlet. Souvisí to s nastavením na meteostanici, firmware adt... Takže to čtu z toho xml. Nevím jaké to má výhody či nevýhody ale funguje to tak už 3 roky 🙂


ReplyQuote
koldavideo
(@koldavideo)
Noble Member Moderator
Joined: 4 years ago
Posts: 1545
17/12/2018 10:33 am  

Přesná odpověď na můj problém s adresací byla tato :

"ModBus" - jelikož ModBus může využívat dva typy značení pro adresaci, tak v některých nadřazených systémech (např. Loxone) je nutné od adresy senzoru na meteostanici odečíst -1 - např. pokud je na meteostanici adresa 1002, pro komunikaci je nutné použít adresu 1001. Je tudíž možné, že nyní vyčítáte jiný senzor, než který zamýšlíte. - vyzkoušejte tuto možnost a informujte nás zda se problém vyřešil.

Tím zřejmě mysleli to, že můžeš číst buď 16 bitů nebo 32.


ReplyQuote
Vandit
(@vandit)
Active Member
Joined: 2 years ago
Posts: 7
17/12/2018 10:45 am  

Ja som to tak mal a kym boli vonku plusove teploty mi ukazovalo vsetko ok, ale akonahle islo pod 0 uz to blblo a ukazovalo  6549,3 a podobne.


ReplyQuote
koldavideo
(@koldavideo)
Noble Member Moderator
Joined: 4 years ago
Posts: 1545
17/12/2018 11:06 am  

Ano to je to o čem píšu. Zkusil jsi tu adresu snížit o jedna? Tím by se vysvětlilo to, co mi psali z toho helpDesku.


ReplyQuote
Vandit
(@vandit)
Active Member
Joined: 2 years ago
Posts: 7
17/12/2018 11:10 am  

Ano vsetky adresy som tak mal a ostatne aj tak funguju, len s teplotami mam problem, ale este mozem tam skusit, ze tam nedam -1.


ReplyQuote
koldavideo
(@koldavideo)
Noble Member Moderator
Joined: 4 years ago
Posts: 1545
17/12/2018 11:14 am  

No ještě podle mně záleží na tom, jestli čteš 16 bitů nebo 32 bitů. 


ReplyQuote
Vandit
(@vandit)
Active Member
Joined: 2 years ago
Posts: 7
17/12/2018 11:41 am  

Citam 16 bit a teraz to ide dobre a nic som tam nezmenil :/


ReplyQuote
koldavideo
(@koldavideo)
Noble Member Moderator
Joined: 4 years ago
Posts: 1545
17/12/2018 11:50 am  

Ještě jedna možnost. Možná byla meteostanice nedostupná ! Vždycky když mám pocit že ukazuje nesmysl, tak jsem ji restartoval. K tomu mám i script, který se nahraje do meteostanice a v určitých intervalech dělá ping na nějakou adresu v síti (router nebo minisever). Pokud nemá odpověď automaticky meteostanici restartuje.


ReplyQuote
smotek7
(@smotek7)
Prominent Member
Joined: 3 years ago
Posts: 835
31/05/2020 9:18 pm  

Ahojte, mam par dotazov k ME13.
ked mam dotazovanie 5s, prekrocenie 20s stale mi chodia notifikacie ze nieje spojenie.
Musim dat prekrocenie na 200s aby mi nehlasilo chybu.
Co mate nastavene?

Ako robite statistiku zrazok v loxone? cez blok elektromer? Na ktory vstup?

Da sa k ME13 pripojit senzor dazda (nie zrazok) aby sa dal vycitat cez modbus?

 

Dik


ReplyQuote
_Petr_
(@_petr_)
Trusted Member
Joined: 2 years ago
Posts: 67
01/06/2020 2:22 pm  

@smotek7 Já měl s modbus komunikací taky problémy a nakonec jsem vyhodnotil jako spolehlivější virtuální vstup a parsování xml.

http://ip-adresa-me13/xml.xml

Co se týče srážek tak ty jsem uspokojivě nerozchodil, dají se použít jen jako informace. Čítání nikdy neodpovídalo tomu, co naměřila meteostanice, prostě se impulzy ztrácely. Nakonec jsem pořídil samostatný senzor deště.


ReplyQuote
smotek7
(@smotek7)
Prominent Member
Joined: 3 years ago
Posts: 835
01/06/2020 2:28 pm  

@_petr_ moc sa mi to prerabat nechce, uvidim ci to bude schodit s tymi 200s

Mne celkom zrazky sedia za den v meteo ( porovnavam s meteostanicov letiska cca 1km vzdialenou).

Senzor mas dazda alebo zrazok?


ReplyQuote
_Petr_
(@_petr_)
Trusted Member
Joined: 2 years ago
Posts: 67
01/06/2020 2:42 pm  

Meteostanice mi měří asi dobře taky, ale když jsem chtěl číst pulzy srážkového senzoru, tak se výsledek v Loxone lišil od meteostanice.

Senzor mám tento https://www.electroschematics.com/optical-rain-sensor-rg-11-review/


ReplyQuote
smotek7
(@smotek7)
Prominent Member
Joined: 3 years ago
Posts: 835
01/06/2020 9:16 pm  

@_petr_ ale podlamna netreba citat impulzy, podlamna sa ani nedaju.
Treba vycitat mnozstvo zrazok a pipojit na spravny vstup.

Som opticky senzor este nevidel solo.
Zatial jedine v aute.


ReplyQuote
_Petr_
(@_petr_)
Trusted Member
Joined: 2 years ago
Posts: 67
01/06/2020 11:05 pm  

@smotek7 Omlouvám se, pamatoval jsem si to špatně. Impulzy jsem chtěl nějak získat, protože přes modbus i xml se dají sice číst data, ale zpracování v elektroměru mi nedávalo správné výsledky. Chtěl jsem nějak získat informaci o srážkách za poslední den/týden.

Problém jsem měl v tom, že do elektroměru je potřeba dávat buď impulzy, změny od posledního měření nebo celkovou hodnotu. Ani jedno jsem nedokázal získat. Jestli se nepletu, tak jsem řešil data kolem půlnoci,  a pak možná i to, že  meteostanice používá u dat GMT.

Pokud se ti podaří najít řešení, tak by mě zajímalo.


ReplyQuote
smotek7
(@smotek7)
Prominent Member
Joined: 3 years ago
Posts: 835
02/06/2020 2:35 pm  

@_petr_ budem este skusat, ked sa nieco podari dam vedet.
To GMT ma ani nenapadlo ze moze byt problem.


ReplyQuote
Page 5 / 7
Share: