Instalace WEEWX pro IP meteostanice EFWS 2900 a ji podobne

Instalace WEEWX pro IP meteostanice EFWS 2900 a ji podobne

You are here:
  • KB Home
  • Hardware
  • Instalace WEEWX pro IP meteostanice EFWS 2900 a ji podobne
< Zpět

 

INSTALACE WEEWX pro IP Meteostanice v systemech zalozenych na Debianu(Ubuntu, Raspbian ..)

Nejdrive je treba rict,kde se ma weewx hledat

wget -qO - http://weewx.com/keys.html | sudo apt-key add -
sudo wget -qO - http://weewx.com/apt/weewx.list | sudo tee /etc/apt/sources.list.d/weewx.list

Pokud nemate nainstalovany WGET, tak provedte jeste

sudo apt install wget

Provede update systemu:

sudo apt-get update
sudo apt-get upgrade

No a ted jiz nainstalujeme WEEWX

sudo apt-get install weewx

 

Na prvni strance vyplnime nepodstatne udaje, Jmeno a kde je MeteoStanice umistena a dame OK.

Nasledne zemepisne souradnice nasi Meteostanice, OK.

Nadmorskou vysku,kde je meteostanice, OK.

Zvolime jednotku, tedy Metric(km/h, mm, °C, mbar), OK.

A zde je dulezite nastavit spravny typ stanice, nas zajima Simulator, ktery zpracovana data prave z IP Meteostanice, ktera nema moznost posilat data primo, OK.

Dale je nutne nainstalovat apache

sudo apt-get install apache2

no a jako posledni balicek je potreba stahnout a nainstalovat plugin do Weewx.

wget -O weewx-interceptor.zip https://github.com/matthewwall/weewx-interceptor/archive/master.zip
sudo wee_extension --install weewx-interceptor.zip
sudo wee_config --reconfigure --driver=user.interceptor --no-prompt

Nez Weewx spustime, je nutne udelat par zmen v configuracnim souboru weewx

sudo vi /etc/weewx/weewx.conf

Tahle zmena je nutna!!!

najedte az na konec configuraku a zde zmente device_type = observer  ( po instalaci je acurite-bridge) a prijdete jeste radek:
port = xxxx ( na tento port budeme posilat veskerou komunikace,neni nutne, ale je to lepsi)

Dale zmenit interval posilani dat do rozhrani Weewx na 60s. Nezkousejte davat mene, jinak weewx po prvni zmene hodi chybu a zastavi se.

archive_interval = 60

No a kdo chce, muze nasledne posilat data na WunderGround

[[Wunderground]] enable = true a nastavime ID a heslo vasi Meteo,ktere mate na Wunderground

Zmenime zacatek tydne z nedele na pondeli

week_start = 0

A ted jen spustime Weewx

sudo /etc/init.d/weewx start

NUTNE!!!

Bez ceho to nebude fungovat, je presmerovani veskere komunikace(TCP) meteostanice na IP a port, ktery jsme nastavili, kde je Weewx nainstalovan. Tohle ma kazdy router jinak, takze to popisovat nema smysl.

No a pokud se vse podarilo, staci se propojit na http://IP_weewx/weewx/ , kde uvidime neco takoveho

A jako posledni, jeste plugin, ktery dava udaje do XML

wget http://android.teszdesign.hu/xml_templates/weewx_pws.xml.tmpl.tar.gz
tar zxvf weewx_pws.xml.tmpl.tar.gz
sudo mkdir /etc/weewx/skins/Standard/XML
sudo cp weewx_pws.xml.tmpl /etc/weewx/skins/Standard/XML/weewx_pws.xml.tmpl
sudo chmod 644 /etc/weewx/skins/Standard/XML/weewx_pws.xml.tmpl

Uprava configuracniho souboru skins.conf

sudo vi /etc/weewx/skins/Standard/skin.conf

 

Pod [[[MobileRadar]]] pridame:

[[[XML]]]
    template = XML/weewx_pws.xml.tmpl

 

Restartujeme Weewx

sudo /etc/init.d/weewx restart

zadame http://IP_weewx/weewx/XML/weewx_pws.xml a meli bychom videt neco takoveho:

 

Pokud by nekde chtel dostat treba UVI nebo Solarni radiaci, staci do souboru weewx_pws.xml.tmpl pridat radky:

<!--UV-->                                                                                                                                                                                                                                                                                                                  
<realtime><data realtime="UV">$current.UV.formatted<!--UV--></data></realtime>                                                                                                                                                                                                                                             
<!--RADIATION-->                                                                                                                                                                                                                                                                                                           
<realtime><data realtime="radiation">$current.radiation.formatted<!--radioation--></data></realtime>

Vnitrni teplota + vlhkost

<!--inTEMP-->
<realtime><data realtime="inTEMP">$current.inTemp.formatted<!--inTEMP--></data></realtime>
<!--inHUM-->
<realtime><data realtime="inHUM">$current.inHumidity.formatted<!--inHUM--></data></realtime>

 

Pridat lze samozrejme vice informaci, viz dokumentace weewx.

Pomohl Vám náš blog? Chcete nás podpořit? I málo udělá radost 😉
Poslední úprava článku February 13, 2019

35 thoughts on “Instalace WEEWX pro IP meteostanice EFWS 2900 a ji podobne

  1. Ahoj, super návod!
    Mám teda meteostanici WH2600, ale udělaný to mám skoro stejně.
    Z jakýho důvodu prosímtě děláš na konci ten převod do xml?
    Já bych chtěl primárně tyhle data dostat do Grafany, což se mi nedaří:-( Nebyla by to třeba cesta (přes xml)?

  2. Ja to do InfluxDB tlacim pres Node-red. Jestli taky mas, klidne poslu co a jak. taky jsem se s par vecma chvili trapil, ale na foru kluci poradili.

  3. XML vystup se mi podařilo zprovoznit, node-red mam na Rasp nainstalovany ale popravdě nevím co v node-redu teď dělat dál. Čumím tu na to a sem trochu bezradnej 🙂

  4. Tak to uz mas skoro vyhrano :)) Node-Red ma vyhodu, ze jde poslat cely FLOW nebo jen cast.
    Udelam Ti export pro Weewx,influnxdb. Takze si pak jen nastavis Grafanu a je to. Yatim do node-red nainstaluj nasledujici moduly:

    node-red-contrib-influxdb
    node-red-contrib-simplejs

  5. Nezkoušel jsi prosímtě z toho dostat i vnitřní teplotu a vlhkost?
    Co jsme zjistil, tak mi ji měří WEEWXu, ale na XML už se to neposílá.

  6. Tuším prosím, kde se nastavuje interval, v jakém je generován ten XML soubor? Já jsme zjistil že se mi generuje 1x za 3 min. Snažím se to přenastavit na 1x za minutu a nemůžu pořád najít kde to nastavit…
    A ještě druhý dotaz, mám trochu problém s tím, že data v influx mám zpožděná o nějakých 3min37s.
    V grafaně si dělám statistiku denních srážek (hledám v daném dni max. hodnotu srážek) ale díky tomu, že mám data posunutá se mi srážky z předchozího dne dostanou i do prvních 3,5 min následujícího dne 🙁

    1. XML je generovane stejne jako www, cas je dany parametrem ve weewx.conf: “archive_interval = 60” coz je 1minuta

      Weewx, influxdb,node-red, to mas vsechno na jedne masine(virtualu)? Pokud ne, podivej se na nastaveni aktualniho casu, zda tam prave nemas ten rozdil 3min37s. Pripadne udelej pres ntp aktualizaci casu a bude to ok.

  7. “archive_interval = 60” mam nastaveny, to jsem kontroloval. Já teda používám na weewx ještě skin (niculskin) ale v tom by to byt snad nemelo.

    Weewx, Influx, Node-red i Grafana mi jedou na jedny maline (RPI 3B+). A ta by mela mit vlastni cas OK:
    Local time: Fri 2019-03-15 08:42:34 CET
    Universal time: Fri 2019-03-15 07:42:34 UTC
    RTC time: n/a
    Time zone: Europe/Prague (CET, +0100)
    Network time on: yes
    NTP synchronized: yes
    RTC in local TZ: no

  8. Tak po dalším zkoumání to vypadá spíš tak, že data v influx jsou ok. Problém bude asi v tom, že (nevím proč) samotná meteostanice provádí vynulování denních srážek až 3min37s po půlnoci 🙁

      1. add action=dst-nat chain=dstnat comment=”MeteoStanice na RPI” protocol=tcp \
        src-address=IP_METEOSTANICE src-address-list=”” to-addresses=\
        IP_WEEWX to-ports=port_weewx

          1. děkuji, tak to jsem měl, ale myslel jsem že je to špatně, proto mi to nefunguje. Takže já pořád zustal u tohoto. http://IP_weewx/weewx/ kde nic nevidím. Postup jsem dodržel a nikde jsem žádnou chybovou hlášku nevidel. 🙁

  9. Dobrý den taktéž, taky se mi nedaří zprovoznit přesměrování, nastavení na weewx je v pohodě ale myslím že problém mám na přesměrování.

    Mám UNIF USG…stačí apon nějak nasměrovat..díky moc

  10. Stále jsem se nikam nepohnul, byl by prosím někdo tak dobrotivý a pomohl mi se zprovozněním weewx?

  11. podle tohoto návodu jsem se snažil nainstalovat weewx. V Rpi3 mi to píše toto. loxberry weewx[113262]: interceptor: MainThread: empty queue. V mikrotiku mám snad dobře přesměrováno a když zadám http://IP_weewxu/weewx/ tak mi píše chyba 404.

    1. Jinak podle tohoto návodu až do místa kde je psáno o přesměrování dat z meteostanice do weewxu proběhlo vše v pořádku.

    2. Problém je uz v instalaci, nefunguje ti www rozhrani. Osobne mi to na loxberry taky neslo, loxberry ma svuj web server a instalace weewx neupdatne web server a nejede to.

            1. Muzes mi pres PM poslat screen weewx webu? Verze 3.9.1 uz ma totiz nekde jinde potrebne soubory a jinou URL, nedelal jsem update navodu….

  12. /ip firewall nat
    add action=dst-nat chain=dstnat comment=IP_meteostanice protocol=\
    tcp src-address=IP_meteo src-address-list=”” to-addresses=\
    IP_Weewxu to-ports=8000
    a když jsem nechal zapisoval do logu tak tam vidím že to posílá na
    47.100.165.80 ISP:Hangzhou Alibaba Advertising Co.,Ltd. a IP Address:34.221.105.132 ISP:Amazon.com a nejakou ip195.27.31.213 Vodafone v Německu. takže asi mi nefunguje přesměrování.

  13. To se me snazi posilat taky na ty dve IP co pises, treti uz mi to nehazi, co se ted divam.
    Pravidlo v MK mas spravne, mas i nastaveny port v weewx.conf 8000?

  14. Odpusťte jazyk, píšu překladatel, já nevím česky;)
    Dělal jsem všechno krok za krokem a nefunguje to. Musím něco umístit do samotné stanice? Snažil jsem se dát RPI IP v “customized”, ale nefunguje to.
    Jak weewx ví, na které IP stanici je stanice, nebo jak stanice ví, kam mají data odesílat? Tomu nerozumím 🙁

Leave a Reply

Your email address will not be published. Required fields are marked *