X
Forum

Forum

SOLAX X3-HYBRID-10....
 
Notifications
Clear all

SOLAX X3-HYBRID-10.0-M G4

Page 1 / 2

PetrJ
(@petrj)
Active Member
Joined: 2 years ago
Posts: 8
Topic starter  

ahoj, chtěl bych se poptat, zda jste někdo již integrovali hybrydní střídač SOLAX X3-HYBRID-10.0-M G4. děkuji


Quote
chucky
(@chucky)
Estimable Member
Joined: 5 years ago
Posts: 148
 

Zdravím nejaký posun aspoň datasheet s tabulkami registrů...?

Nasel jsem toto... není to na G4 ale G3 snad to bude stejné.

 

https://github.com/squishykid/solax/files/6147937/Hybrid.X1.X3-G3.ModbusTCP.RTU.V3.21-.English.pdf

 


ReplyQuote
PetrJ
(@petrj)
Active Member
Joined: 2 years ago
Posts: 8
Topic starter  
Posted by: @chucky

Zdravím nejaký posun aspoň datasheet s tabulkami registrů...?

Nasel jsem toto... není to na G4 ale G3 snad to bude stejné.

 

https://github.com/squishykid/solax/files/6147937/Hybrid.X1.X3-G3.ModbusTCP.RTU.V3.21-.English.pdf

 

ahoj, já zatím integrováno nemám a ani jsem prozatím nic více k tomu nenašel.

 


ReplyQuote
Undy
 Undy
(@undy)
Active Member
Joined: 6 years ago
Posts: 12
 

Také jsem nově majitelem střídače SOLAX X3 GEN4 a tak bych rád zakomponoval do Loxone. Nikdo zatím v CZ neřešil? Vzhledem k tomu, že EON Solax instaluje, tak bude zájemců o propojení s LOXONE asi přibývat.

 

Našel jsem pouze tyto informace:
https://www.loxforum.com/forum/german/software-konfiguration-programm-und-visualisierung/99925-solax-power-wechserichter-in-loxone-einbinden

 

https://www.youtube.com/watch?v=MGN4X5-5VQE

This post was modified 3 months ago by Undy

ReplyQuote
mrl
 mrl
(@mrl)
Active Member
Joined: 4 years ago
Posts: 11

ReplyQuote
chucky
(@chucky)
Estimable Member
Joined: 5 years ago
Posts: 148
 

Ahoj,

už mám doma i střídač solax. bohužel mi nebylo dodáno žádné síťové rozhraní.

Pokouším se tedy připojit přes MODBUS RTU extension. Nedaří se mi ze střídače vyčíst žádné hodnoty...

Do střídače jsem připojen přes svorky 4,5 A/B na konektoru COM mám nastavenou rychlos9600 a adresu střádače měním na 10  a nastaven port na 485 (jiná volba jako 485 modbus ve střídači není....

V loxone ani tuk... . 🙁

Zkoušel jsem i přes šablonu v loxone library... ale ani tuk...

 

((Zajímavé je že pokud to zkouším přes rasspebery a brige TCP to RTU.. tak to sem tam hodnoty vrátí.. ale jen nějaké ...a jen jednou...))

Raději bych jel přes origo modbu rtu ext....


ReplyQuote
mrl
 mrl
(@mrl)
Active Member
Joined: 4 years ago
Posts: 11
 

Mám spuštěno na Loxberry s pluginem Modbus Gateway od zmati a funguje naprosto bez problémů, aktualizace po 5sec.

 

 

image

 

 


ReplyQuote
chucky
(@chucky)
Estimable Member
Joined: 5 years ago
Posts: 148
 

Zdravím tak přes loxberry už to jede musel jsem tam nechat jen 1 zařízení a restartovat službu....

Ale na přímo přes MODBUS ext. ani tuk... extensions funguje s jiném zařízením...

Komunikuji rychlostí jen 9600...kdo mě nakopne...? 🙂

obrazek

ReplyQuote
kobra23
(@kobra23)
Noble Member Moderator
Donator
Assistor
Joined: 6 years ago
Posts: 1981
 

Na Modbus Extension můžeš mít jen zařízení, která komunikují stejnou rychlostí a tuto mít nastavenou v Modbus Extension.

Pokud máš zařízení s 2 různými rychlostmi a nejdou sjednotit, musíš mít 2 různé Modbus Extensiony a každý s jinou rychlostí.


ReplyQuote
chucky
(@chucky)
Estimable Member
Joined: 5 years ago
Posts: 148
 

Zdravím,

jasně na ext. Loxone mám připojen jen ten střídač... mám dokonce i propojeny země..

propojení mám teď na test jen na 2m kabel upt

 

když vyměnim loxone ext za loxberry tak tam země propojené nemám a jede to.. ani zakončovací odpor nemám

 

záhada... 🙂

obrazek

ReplyQuote
smotek7
(@smotek7)
Noble Member Moderator
Documentator
Joined: 6 years ago
Posts: 1546
 

@chucky urcite mas spravne Modbus adresa, IO adresa, prikaz, datovy typ....
Skusal si prehodit A,B ?
Najlepsie je pripojit k tomu nieco na monitorovanie, nejaky USB RS485....
Najrychlejsie je vytiahnut zo sufliku RS485 extension a vidis to v monitore 😀 


ReplyQuote
chucky
(@chucky)
Estimable Member
Joined: 5 years ago
Posts: 148
 

@smotek7 snad vse mám ok kdyz me to pres loxbery jede..

ale .. můžu tedy ješte paralerně připojit RS485 extension..? ptám se protože ho mám.. tak bych zkusil...


ReplyQuote
smotek7
(@smotek7)
Noble Member Moderator
Documentator
Joined: 6 years ago
Posts: 1546
 

Mozes tak to robim.
Odsleduj co posiela loxberry a vracia a potom modbus.


ReplyQuote
roman_b
(@roman_b)
New Member
Joined: 2 months ago
Posts: 1
 

Ahoj, tak mohu potvrdit, podařilo se mi zprovoznit Loxone+ModBus+Solax hybrid X3-G4.

Na Solaxu musíte nastavit rychlost (9600 nebo jinou) a adresu komunikace (standardně 1). Celá zrada je v komunikaci, která je 8 bitová a hlavně bez parity = a toto nastavit nelze. Pokud máte na ModBus fungující elektroměry, většina výrobců podporuje pouze sudou paritu (even). Takže budete muset přidat další ModBus.

Kontrolní měření:

pokud správně napojíte COM kabel na Solaxu (RJ45), tak na modrém páru kontakt 4 a 5 změříte digitálním voltmetrem 5V (4-485A je kladný, 5-485B je záporný). A pokud čtete dokumentaci, zjistíte, že Solax vám ještě na vedlejším zeleném páru č. 3 a 6 dává 13V (tak to hlavně nezkratujte), pak už stačí pouze připojit na modbus loxone a správně nakonfigurovat.

Díky všem za předchozí komunikaci, hodně pomohla....

Roman.

 

This post was modified 2 months ago by roman_b

ReplyQuote
chucky
(@chucky)
Estimable Member
Joined: 5 years ago
Posts: 148
 

tak potvrzuji i v modulu wifi je modbus TCP..  stejně jsem s tím měl problém

a musel jsem ve střídači vrátit adresu na 1 potom vše začalo fungovat...

 

loxone extension uz tunit nebudu neni potreba..

děkuji!


ReplyQuote
Page 1 / 2
Share: